Service Performance Issues

Incident Report for SNOMED International Tooling

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 14:44 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 22, 2026 - 14:02 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 22, 2026 - 11:57 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 22, 2026 - 10:38 UTC

Identified

The issue has been identified as significant misuse of our API's. We are attempting to block this traffic and investigate a solution.
Posted Apr 22, 2026 - 09:03 UTC

Investigating

We are receiving reports of performance issues with this service. The team are currently investigating and will post an update shortly.
Posted Apr 22, 2026 - 08:25 UTC
This incident affected: Public SNOMED Browser.