Refset and Translation Service Unavailable
Incident Report for SNOMED International Tooling
Postmortem

This outage was due to an automated database software update which required a specific flag to be set on the connection string. As this string was not set by default it caused the application to lose its connection to the database. We added the flag and restarted the service and it recovered the connection without any further issues.

We have identified other services potentially affected by this update and are planning to do emergency maintenance to add the flag now before the automated update happens to prevent an unexpected failure of the services.

Posted Apr 30, 2021 - 09:26 UTC

Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 15:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 15:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 29, 2021 - 15:01 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2021 - 14:27 UTC
This incident affected: Refset and Translation Service.