Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 09:31 UTC
Scheduled
This service will be undergoing some urgent unplanned maintenance from Thursday 24 April 2025, 09:30UTC until Thursday 24 April 2025, 09:45UTC. During this time the service will be unavailable. Unplanned downtime required for urgent fix. Service will be unavilable for about 15 mins
Posted Apr 24, 2025 - 09:15 UTC
This scheduled maintenance affected: Public SNOMED Browser.